Mercury Parts       Mercury Marine Parts
 
Mercury Marine Parts Forum Mercury Outboard Parts Discussion Forum MerCruiser Parts Boat Parts MerCruiser Parts Forum Outboard Motor Parts Contact Us
Mercury Parts Mercury
  #1 (permalink)  
Old 09-13-2005, 04:57 PM
Junior Member
 
Join Date: Sep 2005
Location: Michigan
Posts: 1
Post

I have a 1988 mercruiser alphaone that will crank and crank but will not start, it acts like it wants to but will not. Right before it died the engine lost power and the baot was not going as it usually does. Could this have any thing to do with the distributor of should I look at something else? The carborator is getting fuel that is the first thing I eliminated.

Any help is greatly appreciated

Thanks
James
Reply With Quote
  #2 (permalink)  
Old 05-22-2010, 09:17 AM
Super Moderator
 
Join Date: Jan 2005
Location: Lake Placid, Fl
Posts: 1,989
Default

Check spark to see if ignition system is working.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
150 black max wont go over 3000rpm heiko592 Mercury Outboard Parts Forum 2 05-16-2007 10:26 PM
1971 merc 135 wont go in reverse Cord Mercury Outboard Parts Forum 1 05-07-2007 08:50 AM
engine swap fishinfool Mercury Outboard Parts Forum 1 01-22-2005 01:26 PM
Hi, I have a 1979 Mercury V-150.The trouble starts everytime I start the engine in th <HarrysFishingBoat> Mercury Outboard Parts Forum 2 01-13-2005 01:17 PM
2003 merc saltwater died & wont restart <Lyles Fishing Tips> Mercury Outboard Parts Forum 1 11-17-2004 10:09 AM

All times are GMT -4. The time now is 06:15 AM.

Outboard Parts

Other Forums
Yamaha Parts
Suzuki Parts
Evinrude Parts
Johnson Parts
Honda Parts

Copyright 2000 - 2014, Outdoor Network LLC