Mercury Parts       Mercury Marine Parts
 
Mercury Marine Parts Forum Mercury Outboard Parts Discussion Forum MerCruiser Parts Boat Parts MerCruiser Parts Forum Outboard Motor Parts Contact Us
Mercury Parts Mercury
  #1 (permalink)  
Old 11-27-2017, 04:57 PM
Junior Member
 
Join Date: Nov 2017
Posts: 1
Default 7.4/Bravo II "slips" when trying to plane

Hello forum,

I've got a 1993 290 Sundancer with a 7.4L/Bravo II. I've listed this problem on other forums and have had good feedback but I like to solicit several opinions to make a good decision with.

Here is the issue:
When trying to get up on a plane, the outdrive seems to "slip"......not come out of gear mind you, but it definitely causes the engine to "over-rev" and I have to to throttle back to idle to get the prop to "bite" again. My RPM's seem fine (will run up to 4500) and the old girl is trying to get on top but just when it seems like it will break out....this occurs.
Items I've checked:
Trim tabs - all the way down
Trim - all the way down
Prop hub - has not slipped (verified with marks and at a prop shop)

Feedback has been that the coupler from the engine to the input shaft may be bad but I would think that would fail outright. If this is the case, I believe I have to pull the engine to replace it. I just want to be sure this is my last option before taking on this time consuming (and expensive) project.

Thanks for your comments and help!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 02:29 PM.

Outboard Parts

Other Forums
Yamaha Parts
Suzuki Parts
Evinrude Parts
Johnson Parts
Honda Parts

Copyright 2000 - 2017, Outdoor Network LLC