Mercury Parts       Mercury Marine Parts
 
Mercury Marine Parts Forum Mercury Outboard Parts Discussion Forum MerCruiser Parts Boat Parts MerCruiser Parts Forum Outboard Motor Parts Contact Us
Mercury Parts Mercury
  #1 (permalink)  
Old 06-13-2011, 03:53 PM
Junior Member
 
Join Date: Jun 2011
Posts: 1
Default 2000 Mercruiser 5.0 EFI Idle Problems

Hi

I have a 5.0 EFI Mercruiser engine on a 290 Sea Ray. When it is in idle and when switching from forward to reverse then back to idle position, the engine will rev up and down on it's own in idle and sometimes die. This is problematic when it comes to docking. I have changed the computer, the throttle body, the IAC valve, all the sensors from one engine to the other. I put new gas in it, checked the fuel pump and filter. I am out of ideas, my next step would be the wiring harness, what do you think?
Reply With Quote
  #2 (permalink)  
Old 06-13-2011, 04:58 PM
Senior Member
 
Join Date: Feb 2011
Location: Fl. Keys
Posts: 157
Default

Change your transom shift cable
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 07:56 PM.

Outboard Parts

Other Forums
Yamaha Parts
Suzuki Parts
Evinrude Parts
Johnson Parts
Honda Parts

Copyright 2000 - 2014, Outdoor Network LLC