Buy Mercury Parts
Buy Mercury Marine Outboard Parts

Announcement

Collapse
No announcement yet.

1995 Mercury 175hp xri Voltage Regularot Failure

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1995 Mercury 175hp xri Voltage Regularot Failure

    Am in the process of rebuilding Mercury OG147264, including installing a new power head. While testing the new unit, discovered that both voltage regulators are burned up. Not sure when this happened. New ones are on order, but before I install them was hoping someone could offer information on likely cause of this failure. Would hate to burn up the new ones. The output voltage of the stator, with regulators installed is 24-33 VAC. Both regulators are visibly burned. The battery is connected with correct polarity, and, as far as I know, has never been miss connected. I have pictures, but can't figure out how to include them in this post. Any advise would be appreciated.

  • #2
    That does happen for unknown reason's , make sure battery cables connections are clean and tight, don't use wing nuts on battery post use hex nuts. Don't disconnect battery cable or switch battery switch off when engine is running. look for loose or broken ground wires on engine block. Load test batteries to make sure they are ok.
    Regards
    Boats.net
    Mercury Outboard Parts
    MerCruiser Parts
    Force Outboard Parts
    Mariner Outboard Parts

    Comment


    • #3
      Thank you for your response. I really do appreciate it.

      Comment

      Working...
      X